Those who are facing problems while using Digital Signature Certificate (DSC) in https://www.epfindia.gov.in/ site may follow the under mentioned instructions/settings for verification of epf member’s details like KYC details/Online claims/Online name change requests etc. Mozilla Firefox is a browser where one can easily use the DSC without any error.

Step – 1 Install Mozilla Firefox 38.0.1 and install in your system. Download.

Step – 2 After installation open the Mozilla Firefox Then Click on Open Menu, Three Lines below to Browser close Button then Click on Options.

Mozilla Firefox Menu Page
Mozilla Open Menu

Step – 3 There will open a window Click on Advance Option then go to update option. Finally choose Never check for updates (not recommended: security risk) and click on OK.

Step – 4 Again Click on Open Menu, Three Lines below to Browser close Button then Click on Add-ons.

Mozilla Firefox Add-ons
Mozilla Add-ons

Step – 5 Click on Plugins and ensure Java Deployment Toolkit and Java (TM) Platform SE is showing in browser.

Mozilla - Add-ons - Plugin Page

If not showing in browser then Install only Java Runtime Environment 8 Update 171. Download JRE 8 Update 171 and install then restart the Mozilla Firefox.

Check here for Java Configuration.

Also Read: Approve KYC through DSC (Digital Signature)

If you liked this article, share it with your friends and colleagues through social media. Your opinion matters, please share your comments. Like us on Facebook


  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
73 thoughts on “Requirement of Browser & Java Version for EPF Unified Portal”
  1. Thanks a lot for such a valuable information. was struggling from one week to fix this issue.

  2. I have done as u said. I have installed Mozilla Firefox 38.0.1 and latest Java version. All is fine until i get to the final stage and when I click Register DSC it is showing no USB connected or check the connection and also the private key is not found. But the DSC application is working fine. Pls help me go through this

    1. Before click on Register DSC you need to insert your DSC token to USB slot in your PC. Your issue will be solved.

  3. Whenever I try to click on transfer claims I get this error “1) An Unexpected error has occured.
    Click here for home” Give a solution.

  4. When go through USB token , after some time a massage apper like Application block by JAVA security. At the time of registration of Digital signature on epf site by employer.

  5. I am using windows 10. For PF works I use Internet Explorer 11 and Java 8 update 181. When I want to approve KYC by DSC, it shows error: ” Application blocked by Java Security”. How to overcome it. Should I use a different version of Java or Internet Explorer? Please help me. My email: manthottam2002@yahoo.com

    1. Mozilla Firefox 38.0.1 install karke update ko disable kare and java 8U171 install kijiye apka issue solve ho jayega..

  6. I installed Mozilla Firefox 38.0.1 in my windows 7 64 bit OS. I can login to my portal and can see my DSC as active in status. But when i try to approve with the DSC it shows an error “INFO: UNEXPECTED ERROR OCCURED WHILE SIGNING.Exception = No matching registered digital signatory details found.” even while signing in with the certificate shown in the window.

    1. Sometimes this error occures, so if your DSC is Active then try again later your issue will be solved as it is a temporary technical issue.

    1. Got to your DSC drive after insert of DSC token into your system then run the Application file. If you don’t have any knowledge about application installation so kindly take help of a technician.

  7. Your current browser version no longer supports java.
    You may choose to either use eSign for digital signing or any browser version with java support for DSC

    In EPF portal

  8. I was struggling to approve the KYCs and your article helped me. It worked excellently for me and thank you so much for sharing this article.

  9. i have win 7 ultimate 64 bit
    i install the Mozilla 58 but its not working.
    Then i install Mozilla 38.0.1 and when i run the unified portal of epfo in login portion the captcha is not display
    so i unable to login. (its alos not diplay logo and image in site)
    please solve the solution.

    Email- md.jshb@gmail.com
    cont. 9102415353

  10. i have download firfox 41 version and java but at last i approve dsc then massege show approve activity not java run plz help me sir

  11. Hi
    I have installed Mozilla 38.0.1 version and latest Java , while signing transfer claims in EPFO portal, i am getting the below said error.
    a plugin is needed to display this content
    also i have installed Adobe flash player, but still getting same error
    please help me in this regard.

  12. Our PC is Windows 7 professional (32 bit-Operating System), So which Firefox version we have to install in our system. I am unable to access my EPF & Digital key approvals

    1. Install Mozilla Firefox 38.0.1 and Latest version of Java. After installation of Mozilla disable auto update.

  13. i am trying to open the site in IE . after opening the link & sihn in page get over lap dose not open properly

  14. Hi,

    i am using I.E 11.959.18362.0 update Version 11.0.200 (KB456549) to access
    https://unifiedportal-emp.epfindia.gov.in/epfo/
    Java 8.261
    but screen is not showing properly and also not accepting the DSC.

    compatibilty view setting also added, java latest version installed

    kindly suggest me what is the required changed to be made.

    P.Suvarna

  15. Hi
    I am using windows 7 with 4 gb ram 64bit
    Please send suitable browser for epfo kyc approval dsc sign

  16. Howdy! I know this is kinda off topic nevertheless I’d figured I’d ask. Would you be interested in trading links or maybe guest authoring a blog post or vice-versa? My blog discusses a lot of the same topics as yours and I think we could greatly benefit from each other. If you are interested feel free to send me an e-mail. I look forward to hearing from you! Wonderful blog by the way!|

  17. we are unable to download the java deploy toolkit 32bit 8.0.1910.12 11.191.2.12
    can you share the link to download and run

    1. No need to download java deploy toolkit. Just install the Mozilla Firefox 38.0.1 and latest version of java. Java deploy toolkit will be automatically update.

  18. I had installed firfox 32.0.1 version and latest version of JAVA. But I could not sign Form 5A under EPFO site. An Error Message Showing while signing Form 5A i.e INFO:UNEXPECTED ERROR OCCURED WHILE SIGNING.Exceptions=null”. Kindly help me resolve this issue. The Digital signature that I am using has Got the approval from EPFO also.

    1. Hi,

      Sorry for the delay reply. It is a temporary issue happens sometimes. Hope your issue may be solved.

      Thanks

    1. Hellow,

      You DSC application may be not installed in your system. Kindly install the application before use of DSC.

      Thanks & Regards
      Admin

    1. Hellow,

      You DSC application may be not installed in your system. Kindly install the application before use of DSC.

      Thanks & Regards
      Admin

  19. I just want to mention I am all new to weblog and really loved you’re web page. Probably I’m likely to bookmark your blog . You amazingly have tremendous articles and reviews. Cheers for revealing your web site.

  20. This Connection is Untrusted

    You have asked Firefox to connect securely to http://www.google.com, but we can’t confirm that your connection is secure.

    Normally, when you try to connect securely, sites will present trusted identification to prove that you are going to the right place. However, this site’s identity can’t be verified.
    What Should I Do?

    If you usually connect to this site without problems, this error could mean that someone is trying to impersonate the site, and you shouldn’t continue.

    This site uses HTTP Strict Transport Security (HSTS) to specify that Firefox only connect to it securely. As a result, it is not possible to add an exception for this certificate.

    http://www.google.com uses an invalid security certificate.

    The certificate is not trusted because the issuer certificate has expired.

    (Error code: sec_error_expired_issuer_certificate)

    1. Dear Mr. Asad,

      As the Mozilla 38.0.1 is very older version so some security features are not updated. But this can be use only for DSC work, rather than you can choose other browsers. So ignore the error message and proceed further and once completed DSC work you can switch to other browser for other work.

      Thanks & Regards
      Admin
      Infobuzzadda

  21. We are trying to login EPFO site in Mozila Firefox 32.0.2 but once we press sign in option then it directly goes to home page. please help us out.

  22. That is a good tip especially to those new to the blogosphere. Simple but very accurate info… Appreciate your sharing this one. A must read post!

  23. I installed Firefox 32.0.2 and done as you above suggested but the content displaying in mozila browser is too big. and after putting ID password is not logging in please help

    1. Hellow,

      We though that your issue must be solved as per email sent to you.In case any other issue feel free to write us.

      Regards

  24. Very efficiently written article. It will be beneficial to everyone who utilizes it, including myself. Keep up the good work – i will definitely read more posts.

  25. Now on this setting Mozilla can’t login on this site. What’s the problem please share as soon as possible.

Leave a Reply

Your email address will not be published. Required fields are marked *